C'mon US Postal Service .... You can't do better then that?

December 04, 2020  •  Leave a Comment

Getting so incredibly frustrated.  I treated myself to my first Drone ever, a DJI Mavic Air 2.  I often look to eBay for some deals and seemingly found one advertised as a "Fly More" combo, which includes add'l batteries, a car charger, ND filters, etc. 

Asked the Seller for Serial Number, since I thought I needed that to register the Drone with the FAA (turns out you don't need a SN). So I registered as a recreational Drone pilot on 11/27/2020, since the Drone was to arrive on 11/29/2020.  (The seller did a great job shipping it so quickly).

And this where things get bogged down.  After 1 1/2 days (item shipped from Plainfield, IN on 11/27/2020 - 12:10pm) it arrived in Hyattsville MD. Excellent, figured it should arrive in another day or two.  

Yeah, not so fast Cowboy ...  After several days I decided to check the tracker again, and the package is now heading to VA?  I live in MD - last I checked.  Item is addressed to be delivered in MD.  Uhhh - WTF?

As soon I saw the package heading to VA, I opened a Customer Service Inquire with the USPS (Where is my package, why is it going to VA when it was in MD 9where I live).  So far, I got SILENCE ....


 

I will update this further as needed.  Very frustrated!

 

9 Dec 2020 update:

On Sat 12/5 I received this email from USPS as a reply to the customer inquiry I created

Your package was missent to VA it was processed back out of VA on 12/1/20. Right now we do have some parcel delays and you may not see an update for a few days. Plwase be patient we are working to get parcels delivered as soon as possible.
 

eBay tracking info was updated as follows


 

In the meantime all I have is this ...


This morning I opened another customer service inquiry, asking for a tracking update, since supposedly the package has left VA (how does the USPS person know this?  There is no information that would support this "claim".  Felt like an email just to "shut up" the customer for a few days, and it worked! (well, until this morning anyway).  Update to follow.

 

 

 

 

 

 

   


Comments

No comments posted.
Loading...

Archive
January (1) February (2) March (4) April (6) May (2) June July August September (1) October November December
January (1) February March April May June July August September October November (1) December (1)
January February (3) March April May June (2) July August September October (2) November December (1)
January (1) February (2) March (1) April (1) May (1) June (1) July August September October November December
January February (2) March April May (1) June (1) July August September October (1) November December (1)
January (1) February March (1) April May June July August September October November December (1)
January February March (1) April (1) May June July August September October November December